Fork me on GitHub

Watch

GitHub Core

Show your support for Zikula! Sign up at Github account and watch the Core project!




GitHub Modules

Forum Activity

Forum feed

» Visit forum | » View latest posts

Dizkus install problems  Bottom

  • I would really like to add a forum to by site, but Dizkus is not working for me. I must be doing something wrong. Here is my set up
    Zikula 1.3.3
    Dizkus 3.2
    Theme Andreas08

    First off. Should I also install bbcode, BBsmile and LuMicuLa as the installer asks for? If so, do I grab the ones in github. Right now I am testing on a local server, but this is eventually going on a production server so I would like to avoid broken stuff. I can get Dizkus to install just fine, but I cannot create forums. How do you create forums. I tried going to Edit Forum Tree and then clicking on the create new category button, but nothing happens. A little spinner comes up, but then nothing. Any ideas welcome.
  • Dizkus is not on the list of working modules for 1.3.3. If there was even a slight chance of it working, I would bet you'd need to grab it from the SVN. If I remember correctly the creation of forums is heavily Java based.

    It's possible you could bypass a lot of this by creating all the forums and categories on a 1.2.9 install and updating to 1.3.x ? Just a thought.
  • I was under the impression that it was what is used to run this forum and that they want to use it going forward. Is that incorrect. I will play around with it and see if I can get it working.
  • It's not listed in the modules that is working with 1.3.3, and I'm pretty sure if someone had a way to get it working on 1.3.3 it would be on the list.

    If you've got time, you might try installing on 1.2.9 or 1.3.0, then Dizkus, and then upgrade to 1.3.3, could work. I'd set up the complete forum before updating as you'll most likely not be able to add categories, or sub categories once your into 1.3.3. Even doing this is, there will be a 99% chance of failure?

    Looking at the way things are going here it will most likely be a very long time before Dizkus makes the list of working modules for 1.3.3, and may never make the list until 1.4.x is released. If you REALLY need forums you could move back to 1.2.9 and use PNphpBB2, and of course there are more drastic solutions outside of Zikula.

    I'm running 1.2.9 with PNphpBB2 with no problems. I see no reason to really go past 1.2.9 at this time, other then to keep up with the Jones.

    Good luck...

    BTW, This site is not even running 1.3.x...



    Edited by mesteele101 on May 30, 2012 - 09:28 AM.
  • I was able to make some progress, but there is a ton of javascript in their that makes it do some pretty neat things, but I don’t have the time to get my head around it. Ah well. I am at 1.2.3 on my production server and I am just not going to have those capabilities for a while I guess. It is getting worked on in the github site. I don’t have the background to work on this, but I will work on other aspects of zikula to get this up and running.
  • If you want to try a Dizkus working on 1.3.3, download the .zip of my fork: https://github.com/ccandreva/Dizkus
    I fixed a few problems and am now able to post, comment, and read. I'm not guaranteeing anything else works. icon_smile

    Try that and see if you find any more problems. I've submitted a pull request for my changes.
  • I get that you can post, comment, and read, but you need to be able to create the forums before you can do any of those things you posted.

    Are you able to create the forums and sub-forums from a fresh install?

    I've given up on 1.3.3 at this point, but in the past the problem has been just creating the forums.
  • Yes, sorry, I did this on a fresh install so I could create the forums.

    Right now "View latest posts" isn't working, I'm looking at it.
  • Glad to see you are working on this. I was able to create one category and then add one forum in that category, but then it would not let me continue. The Ajax user interface is working, which is a big improvement, but it will not save a second forum or a second category when you modify it.
  • I just created a new category and added 5 forums to it.

    I think the problem is the interface is confusing. It adds the forum but nothing seems to show that it has if you aren't watching the browser closely. However after each save I could close that forum's fieldset and click add to make another one.

    In fact, I then deleted the 5 forums and topic, and created a new topic and three forums in it. The only thing I couldn't do without hitting reload was delete the first test topic. I am guessing that the HTML is generated without a delete checkbox if there are forums in it. You have to reload to generate the checkbox.

    Can you try and see if this is the case ? Make sure you have the latest code.
  • Glad to see all the activity in Dizkus development, very important to Zikula.

    Is the work at a point to test? Which branch/download is the one to get?

    --
    Damon
    Catamaran Sailing at TheBeachcats.com
  • I think it is ready to test, but I just started fixing things.

    http://github.com/zikula-modules/dizkus has the latest code. You can download a zip file

    While you are at it, try InterCom. I think everything works now except autoresponders . Does anyone actually want autoresponders for web site PM? icon_smile
  • ccandreva

    I think it is ready to test, but I just started fixing things.

    http://github.com/zikula-modules/dizkus has the latest code. You can download a zip file


    Thanks I'll check it out.

    ccandreva


    While you are at it, try InterCom. I think everything works nkw except autoresponders . Does anyone actually want autoresponders for web site PM? icon_smile

    I don't! Always made sure that was turned off, someone must have thought of a use for it originally, maybe something of use for administrators or site owners but sure wouldn't want to make it available to site members. If they all turn it on the auto-responses would be replied to by auto-responses etc.

    --
    Damon
    Catamaran Sailing at TheBeachcats.com

This list is based on users active over the last 60 minutes.