Fork me on GitHub

Watch

GitHub Core

Show your support for Zikula! Sign up at Github account and watch the Core project!




GitHub Modules

Forum Activity

Forum feed

» Visit forum | » View latest posts

Trouble tot Upgrade Clip from 0.4.18 tot 0.9.1  Bottom

  • I copied the contents of the new Clip 0.9.1 folder in my current 0.4.18 Clip folder

    I overwritten the old files

    When I press the “Upgrade Clip” button I get the following message:
    WARN (4): E_WARNING: mkdir(): No such file or directory in Generator.php line 907
    WARN (4): E_WARNING: file_put_contents(/Pubdata1.php): failed to open stream: Permission denied in Generator.php line 874
    WARN (4): E_WARNING: file_put_contents(/Pubdata1Table.php): failed to open stream: Permission denied in Generator.php line 878
    WARN (4): E_WARNING: file_put_contents(/Pubdata2.php): failed to open stream: Permission denied in Generator.php line 874
    WARN (4): E_WARNING: file_put_contents(/Pubdata2Table.php): failed to open stream: Permission denied in Generator.php line 878
    Could not load the 'extensions' module at 'upgrade'.
    Couldn't find class ClipModels_Pubdata1
    Go back to previous page

    When I pres “Go back to previous page” and press the “Upgrade Clip” button again I get:

    Could not load the 'extensions' module at 'upgrade'.
    SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'urltitle'. Failing Query: "ALTER TABLE clip_pubdata1 ADD urltitle VARCHAR(255)

    Was I thinking too easy about this upgrade or did I forget something?
  • Unfortunately after many jumps in the development of 0.9.0 the upgrade path got broken in three parts.

    My priorities went to finish some useful and friendly stuff on clip_plugins and utilities,
    but the upgrade path will be broken until the next major release I guess.

    The upgrade may go fine step by step,
    I will see if I can figure a workaround in the meanwhile hacking the upgrade script to fail in strategic points, and trying again until reach the 0.9

    --
    - Mateo T. -
    Mis principios... son mis fines
  • Thx for your response Mateo,

    I haven't done anything major in this installation of Clip,
    Can i just remove the DB tables of Clip? and start over

    If i remove :
    clip_grouptypes
    clip_pubdata1
    clip_pubdata2
    clip_pubfields
    clip_pubtypes
    clip_relations
    clip_workflowvars

    and install from the Extensions menu again, do you thing that's enough?
  • the deinstallation doesn't work?

    Clip has registries on the workflows and the hooks* table too,
    you will have to clean them manually and try.

    --
    - Mateo T. -
    Mis principios... son mis fines
  • I've just commited an upgrade solution,
    if you have a DB backup you may help to test if it works Ok ;)

    --
    - Mateo T. -
    Mis principios... son mis fines

This list is based on users active over the last 60 minutes.