Fork me on GitHub

Watch

GitHub Core

Show your support for Zikula! Sign up at Github account and watch the Core project!




GitHub Modules

Forum Activity

Forum feed

» Visit forum | » View latest posts

News

Articles | General

Articles: Zikula 1.2.5 Released

Contributed by drak on Jan 25, 2011 - 06:56 AM

General

Zikula Core 1.2.5 (build 230) is available for general release from today. In keeping with our promise to produce a maintenance release 3 to 4 times per year, this release resolves around 30 issues including one potential security flaw surrounding the Users module (thanks to YEHG for reporting). You are recommended to upgrade to Zikula Core 1.2.5 as soon as possible. Please download the latest version from http://zikula.org/infopages/CMS/Download.1.

Bug fix highlights

  • Fixed file type shorturls not working - issue #2520.
  • Fixed special characters not replaced in permalink replacements - issue #2580, #2651, #1924 and #2101.
  • Fixed potential XSS in Users module.
  • Password reset email contains broken link when requested through SSL (issue #2506).
  • Regression - Login function bug for users with special characters since 1.2.x (issue #2273).
  • Problem when editing category registries (issue #2508).
  • Fixed issue with pager calculations (issue #1845).
  • Fixed issues with ImageViewer where JS only works once, improved layout and zoom effect (issue #2681).

Full details are available in the changelog.

Those requiring the patch release, may find it here.

Many thanks to the Zikula Core Development Team and the users who reported these issues.

Enjoy it,
Zikula Team

 

Share    

Comments

Comment by:
espaan's Avatar
espaan
24 Jan 2011 - 09:35PM
Nice work
Great update, thanks.
 
Comment by:
slam's Avatar
slam
25 Jan 2011 - 02:09AM
Super!
Very nice release, already upgraded several sites this morning - no issues.
 
Comment by:
garou-69's Avatar
garou-69
25 Jan 2011 - 06:51AM
heuu
Hello,
I'am encoutering a problem with a upgrade from 1.2.4 to 1.2.5 with module Profil.

when i try to login to Cozi core to open ticket, i obtain an error :
[edited]
IntegrityError: duplicate key value violates unique constraint "session_attribute_pk"
can you help me ?
thanks.
Garou
 
Comment by:
czardogs's Avatar
czardogs
25 Jan 2011 - 06:48PM
updates
Can we update straight from 1.2.3?
 
Comment by:
drak's Avatar
drak
26 Jan 2011 - 12:46AM
@garou-69 - clear all your cookies and try again.
@czardogs - yes you can, just run upgrade.php
 
Comment by:
mesteele101's Avatar
mesteele101
26 Jan 2011 - 01:54PM
Release path?
Is there planes for any more releases of 1.2.x?
 
Comment by:
drak's Avatar
drak
27 Jan 2011 - 01:41AM
Of course: 1.2.6 is slated for April/May - you can see milestones at http://code.zikula.org/core/roadmap
 
Comment by:
eledril's Avatar
eledril
31 Jan 2011 - 01:08PM
Update Was A Snap
I was pleasantly surprised at how easily I was able to update.
 
Comment by:
Teb's Avatar
Teb
02 Feb 2011 - 11:51AM
Changelog
Link to changelog should be updated (trac browser redirects to non-existing tree in github):
https://code.zikula.org/svn/core/tags/Zikula-1.2.5/src/docs/CHANGELOG
 
Comment by:
myths's Avatar
myths
16 Feb 2011 - 01:06PM
patch release
we don't need to run upgrade.php if we used the patch release (from 1.2.4), no?
 
Comment by:
craigh's Avatar
craigh
17 Feb 2011 - 12:48AM
you may need to manually upgrade your modules, yes.
 
Only logged in users are allowed to comment. register/log in